BotVac Connected Issues 905-0249

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

BotVac Connected Issues 905-0249

Postby Dustinzinnj » April 30th, 2019, 5:41 pm

Hey guys, not sure if I just can't find the fixes for these things. Got it off eBay recently, and love it, when it works.

Has anyone been able to remove ALL their old maps and start the robot fresh entirely? I haven't gotten maps since the first few days I had it.

After a cleaning of any kind, there is a big chance it will turn off once it completes. I'm pretty sure this is why I haven't gotten any new maps or anything via the mobile app. It runs great, until it doesn't detect any of the side sensors when hitting something and tries to move the wall, rather than back up. Sometimes it will hard shut off during this (over-current protection?).

Sometimes it will work all the way until it re-docks itself, then it will reboot and start charging.

It has the latest firmware from their site.

It has literally a two day old battery, and even happens during a freshly charged run.

Wifi is enterprise grade (IT business owner, so it's all PFSense router, and UniFi AC Ap's/Switches). We're talking a db of around -60 for average where it's running. It has it's own 2.4Ghz only SSID. No VLANS or anything tricky right now. Only seems to disconnect when it reboots, otherwise it seems fine.

I've done multiple hard and soft resets. (Holding right, and home. and the hold home to turn off and back on).

New side brush belt (Laser belt came in too large, so that will have to wait. Seems to function fine)

Is there something I'm missing, or did I just get a dud that someone abused?

I'm not above replacing caps, or parts on the board, if it's relatively cheap. I'm trying to not send it back through eBay. I am a little worried for my D5 model coming in, since they seems to be relatively the same board inside (although I'm sure the newer ones have better SOCs/memory.).

It also seems fine while using the USB program and checking all sensors.

Thanks
Dustinzinnj
 
Posts: 2
Joined: April 30th, 2019, 3:16 pm

Re: BotVac Connected Issues 905-0249

Postby Dustinzinnj » April 30th, 2019, 11:25 pm

Another note after some more fussing with it.

- Pausing or Stopping from the Neato App will result in a Botvac reboot.
- Letting the Botvac finish its run, it will return to home, but still reboot everytime once it charges on the base.

Both of these reboots are soft, it will keep WiFi settings and return to normal "ready" mode.

No errors of any kind shown on screen or app.
Dustinzinnj
 
Posts: 2
Joined: April 30th, 2019, 3:16 pm

Re: BotVac Connected Issues 905-0249

Postby fmulders » May 8th, 2019, 5:02 pm

You can try one other reset procedure...
  • Shut down by holding the button for 5 sec. till led goes of.
  • remove battery
  • place robot against the charger without the battery and start it up.
  • when it is idle again remove it from the charger and it will switch off because there is no battery

Replace battery and try if this did something for you.
(Procedure was given by Neato support in a similar case)

There is also a procedure to let it boot with an earlier software version. This fallback is in case the upgrade has gone bad. But I do not know by head how it was done. You should try this after the first option from above.

Good luck.
User avatar
fmulders
Robot Groupie
 
Posts: 53
Joined: February 3rd, 2018, 12:25 pm
Location: The Netherlands

Re: BotVac Connected Issues 905-0249

Postby fmulders » May 8th, 2019, 5:08 pm

fmulders wrote:There is also a procedure to let it boot with an earlier software version. This fallback is in case the upgrade has gone bad. But I do not know by head how it was done. You should try this after the first option from above.


Found it:
1. Remove the dustbin from the botvac
2. Remove the botvac from the base
3. Hold the start button for 10 seconds until the unit powers down
4. Press and hold the left front and left side bumper in, and hold the start button for 10+ seconds until the unit powers on
5. Setup the botvac on your phone app (you may need to soft boot the botvac again)
User avatar
fmulders
Robot Groupie
 
Posts: 53
Joined: February 3rd, 2018, 12:25 pm
Location: The Netherlands


Return to Neato Robotics

Who is online

Users browsing this forum: anjosva, im1kissfan, kersian and 290 guests

cron