XV Lidar trouble

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

Re: XV Lidar trouble

Postby benitomeca » May 29th, 2019, 7:27 am

Hello everybody

i replace the slipring and the result is good for the first vaccum test.
I bought the parts in "Senring" factory in China. The ref of parts is SNF-0405.
So it's necessary to modify the hole of laser support because the part isn't exactly the same and the 4 wires are bigger.
Attachments
IMG_1103.JPG
Old part
IMG_1163.JPG
New part
New slipring.PNG
Neato control with new slipring
Robot Laser NOK.JPG
Neato control with old slipring
benitomeca
 
Posts: 4
Joined: January 3rd, 2015, 4:01 am

Re: XV Lidar trouble

Postby masterx81 » May 30th, 2019, 7:14 am

My d5 has't that slipring. The laser unit is powered by induced power from a widing, and the trasmission seem optical via ir sender/receiver (i think timed via an ire sensor that senses the laser rotational speed (and also the angle).
So they have made the new versions a bit better.
masterx81
 
Posts: 10
Joined: May 9th, 2019, 5:08 am

Re: XV Lidar trouble

Postby glnc222 » May 30th, 2019, 5:50 pm

One improvement in the Botvac makeover from the original XV was a Vorwerk lidar with optical signal coupling according to original descriptions. Maybe used in the original Vorwerk XV, VR100 compared to the Neato Robotics models. I think the Botvac lidar though, is still signal compatible with the XV and guessing can be used in XV models for replacements (the slip ring is an internal lidar part).

[edit] See French post of the slip ring replacement
https://www.kelrobot.fr/forum/xv-defaut-laser-erreur-4xxx-solution-t4955.html
glnc222
Robot Master
 
Posts: 4943
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Previous

Return to Neato Robotics

Who is online

Users browsing this forum: Atena, BrettS, fufu, im1kissfan, jdong, johnnyh, rob111gb, someoneclever, sondejmarek, StefanKrupop, TechGuy, tre, vicdeng and 385 guests

cron