Samsung Smart Home app cannot add device

News and information about the Samsung Navibot, Tango, Furot and VC series Robotic Vacuums. All discussion and troubleshooting questions go here.

Samsung Smart Home app cannot add device

Postby impaladb » February 1st, 2019, 9:53 pm

I've had a powerbot 9040 for some time and had it registered on the Samsung app and it was working fine.

I recently got a 9250 and wanted to add it to the app. I had un-registered the 9040 from the app last week. So I log in to the app and go to add device. It asks for username and login password then goes to what appears to be some scripting error like a bad web site.

I uninstalled the app and reinstalled, same problem. Tried on my android tablet, same errors.

So I wondered if there was an issue with the 9250 and tried to add the old 9040. Same error.

Looking at the Google play store reviews of the app there seems to be a lot of complaints of users having the same issue. Not just with the powerbot but with any Samsung smart devices that worked in the past.

Samsung support was unable to help. They ran the serial number of the 9250 and said there was no reason I should be having issues.

Anyone have any suggestions?
impaladb
 
Posts: 1
Joined: January 12th, 2019, 12:27 am

Re: Samsung Smart Home app cannot add device

Postby glnc222 » February 2nd, 2019, 6:41 pm

It sounds like you were never logged in because of some outage of the account server, which might be different than the app server -- they converse, details unknown. There have been cases of Samsung servers not always available. When talking to customer service maybe you can get the problem escalated to someone who can report to the server operators. It can depend on the country in which you are located. Maybe a warranty claim will attract their attention. I am not much of a fan of these WiFi apps on vacuum robots -- their function is not all that complicated to have much use for such interfaces, IMHO. A matter of taste.

The U.S. Samsung site does have user forum to which you might post something about this. Sometimes the moderator has more connections in the company than customer service reps, deluged with customers trying to find the wall outlet...
glnc222
Robot Master
 
Posts: 4846
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.


Return to Samsung Robots

Who is online

Users browsing this forum: 3kgt, BrettS, drunkpenguin, im1kissfan, jdong, KeldBroe, martin.schwarzinger2, ps0001, RockinRay and 381 guests