Roomba 530 and bluetooth adapter - no success!

Inside the Roomba and Scooba and more, Cool mods, Repair and Upgrades - including the all new iRobot Create Kit. Let's void that warranty baby!

Re: Roomba 530 and bluetooth adapter - no success!

Postby iDestroy » March 31st, 2009, 5:27 pm

I have purchased the new Rootooth as well and noticed that the POI4 (hardwired switch) is in the on position when you poll the switch through display commands (&). This switch defaults the baud rate to 9600 regardless of what the software setting is, so if you do the $$$, SU,57600 (for the iRobot Create) to set the buad rate to 57600, when you recycle power on the rootooth defaults to 9600. Sparkfun does not have documentation on fixing this. Has anyone else veryfied this??
iDestroy
 
Posts: 1
Joined: March 31st, 2009, 5:23 pm

Re: Roomba 530 and bluetooth adapter - no success!

Postby vic7767 » March 31st, 2009, 5:41 pm

Factory Reset- is PIO4. Set this switch/PIO4 on powerup. This arms the reset function. Then toggle the
switch/PIO4, 3 times and all settings in the device (other than the Bluetooth name) will return to defaults.

Baud Rate select - is PI07. used to configure 9600 or software selected (default=115K ) baudrate. If the switch
is OFF, the stored baudrate setting will be used. When the switch is in the ON position, the baudrate will
be set to 9600 regardless of the software setting.

These two statements are copied from the Blueport pdf document.
Roomba and Neato Mods, come visit: http://www.vic7767.com/
User avatar
vic7767
Robot Master
 
Posts: 14944
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: Roomba 530 and bluetooth adapter - no success!

Postby El-guy » November 3rd, 2010, 2:13 pm

I tried the exact same thing using this serial Bluetooth adapter, I had no problems connecting, however had to spend a few minutes configuring and setting up the unit. :cheers:
El-guy
 
Posts: 1
Joined: November 3rd, 2010, 2:11 pm

Previous

Return to Robotic Hacking

Who is online

Users browsing this forum: BrettS, hage.ny, im1kissfan, jdong, Miles267, vic7767 and 366 guests

cron