Mi Robot vacuum - Error 1

Questions and comments about all other Robots go here.

Mi Robot vacuum - Error 1

Postby level380 » July 19th, 2018, 6:12 am

Hi there,

My Mi Robot vacuum has started to give the

error 1 - Try turning the orange laser head to make sure it isn't blocked.

Couldn't find a thread on here, so thought I would start one. Google tells me its the laser that has died, as my LDS is spinning around etc and seems a common fault.

Does anyone know how to verify the LSD laser is working correctly?

Is this a visible light that I can see? I've had a quick look and can't see anything, nor is a phone camera showing anything (yeah the old IR trick).

Its either $15 in parts or $100USD in parts depending on the issue. One being the laser only, the later being the entire LDS unit.

Thanks
level380
 
Posts: 5
Joined: March 12th, 2013, 11:21 pm

Re: Mi Robot vacuum - Error 1

Postby level380 » July 19th, 2018, 6:53 am

So I pulled the unit apart to look at the LDS unit, as its very easy to get out. Nothing jumped out at me, put it back in and started the unit. Away it went.

I've already done a few 'power offs' and on again, so I don't think it was that.

Guessing maybe a bad connection? Who really knows. But the unit is busy cleaning the floor as I type this. The lidar map looks fine in the app. Guess only time will tell.

level380 wrote:Is this a visible light that I can see?


Well to answer my question, thats a yes. You have to get at the right 'level' to see it.

Sorry for the bad picture, but its a red light

https://postimg.cc/image/89e2h2gtj/
level380
 
Posts: 5
Joined: March 12th, 2013, 11:21 pm

Re: Mi Robot vacuum - Error 1

Postby Nphilm » May 23rd, 2019, 3:50 am

Had the same problem. Found a small stick blocking the lidar units timing belt. Runs fine now.
Nphilm
 
Posts: 1
Joined: May 23rd, 2019, 3:48 am


Return to All Other Robots

Who is online

Users browsing this forum: BCCISProf, BrettS, im1kissfan, I'mNotARobot, KeldBroe, ps0001 and 392 guests