Neato going in reverse and in circles

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

Neato going in reverse and in circles

Postby anamika » May 28th, 2014, 3:40 pm

My Neato is going backward trying to climb on the charger. When it's on the bare floor and I start it up, it starts going backwards and in circles.

What could be the problem?
anamika
 
Posts: 3
Joined: May 28th, 2014, 2:19 pm

Re: Neato going in reverse and in circles

Postby vic7767 » May 28th, 2014, 3:48 pm

Possibly a stuck bumper sensor or even a cliff sensor fault.
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 14409
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: Neato going in reverse and in circles

Postby anamika » May 28th, 2014, 4:21 pm

Any idea how to fix those issues?

Thanks
anamika
 
Posts: 3
Joined: May 28th, 2014, 2:19 pm

Re: Neato going in reverse and in circles

Postby vic7767 » May 28th, 2014, 4:28 pm

If under warranty contact the warranty provider for a replacement. If not under warranty then diss-assembly will be necessary to determine what may be at fault. Also go to the NeatoRobotics website and read about the input messages that can be used to help determine the failing sensor.
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 14409
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: Neato going in reverse and in circles

Postby anamika » May 28th, 2014, 4:41 pm

Vic: The LCD is not showing any error messages. Where would the input message be?
anamika
 
Posts: 3
Joined: May 28th, 2014, 2:19 pm

Re: Neato going in reverse and in circles

Postby vic7767 » May 28th, 2014, 5:28 pm

The reference is to the input messages that must be typed in using a computer and a terminal program that is connected to the Neato mini USB port.

Here is a link to the programmers manual that contains the procedure as well as the commands:
http://www.neatorobotics.com/resources/ ... to,-51,792
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 14409
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: Neato going in reverse and in circles

Postby F_Robot » November 4th, 2014, 11:40 am

If the housing is not correctly installed (after disassambling) or the lidar is not engaged in the ball bearings correctly, the cleaner can see its own housing.
Then he goes circles.
I have the front lidar mounting points increased by about 1mm.
Attention to watch and see whether the lidar later still turns easily and does not stumble in the case.
Neato VX-11, LION-Ion Sony Konion 8x 2250mAh, Vorwerk filter+brush with ball bearings
F_Robot
 
Posts: 5
Joined: March 12th, 2014, 4:44 am

Re: Neato going in reverse and in circles

Postby neat99 » November 4th, 2014, 1:46 pm

I have this problem too. It's intermittent. At times it would run without issues. There are times when in the middle of the run, it would start traveling backwards in circles. My workaround is to do a long press on the power button to reset the run. Sometimes it works and sometimes it doesn't. Very annoying and frustrating. :(
neat99
 
Posts: 35
Joined: June 18th, 2013, 1:11 pm

Re: Neato going in reverse and in circles

Postby F_Robot » November 8th, 2014, 9:46 am

neat99 wrote:I have this problem too. It's intermittent. At times it would run without issues. There are times when in the middle of the run, it would start traveling backwards in circles. My workaround is to do a long press on the power button to reset the run. Sometimes it works and sometimes it doesn't. Very annoying and frustrating. :(


Now I have this problem too. Sometimes he turn around for minutes and the he do a normal job.
Sometimes the problem is on the end of job.
I do the same like you and reset him. It looks that he didn´t know right direction.
All sensors looking good. :|
Neato VX-11, LION-Ion Sony Konion 8x 2250mAh, Vorwerk filter+brush with ball bearings
F_Robot
 
Posts: 5
Joined: March 12th, 2014, 4:44 am

Re: Neato going in reverse and in circles

Postby glnc222 » November 8th, 2014, 2:02 pm

Reports of lidar spin motor failure with worn brushes and reports of dirt in the drum bearing, with a contact ring for signal coupling can mean possible intermittent rotation errors with partly worn components.
The only practical way to tell is replace with a new Lidar and see if it performs better over long periods.
Age of the vacuum could be suggestive, and how intensively it is used.
Also the replacement Jameco lidar motor found.
I am not sure there is any source for brand new factory lidar units, only units pulled from used machines.
The lidar scan data over USB might show a difference between old and new lidar motors. I used to see a lot of error messages from the lidar even though the vacuum mostly ran correctly. Yet this suggests some sort of intermittent failure happening all the time. I had no unused unit to compare.
glnc222
Robot Master
 
Posts: 4616
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: Neato going in reverse and in circles

Postby glnc222 » November 8th, 2014, 2:41 pm

The classic reason it goes in circles is from dirt on the wall or cliff sensors, which pushes it away in all directions like it is inside a box.
Maybe only some dirt causes intermittent effects. Easily inspected.
glnc222
Robot Master
 
Posts: 4616
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: Neato going in reverse and in circles

Postby Lewiy » November 9th, 2014, 6:28 am

My Neato had the same issue. I found a splinter of the transparent plastic (coverslip) which covering one of the cliff sensor on the bottom. It dangled in a cavity between glass and the sensor. I could only see it when lit there. Neato improved after deleting the splinter. After a while the same issue had repeated from the opposite side.
Coverslip of this sensor has two legs (clips) for fixing. They look too brittle.
Lewiy
Robot Master
 
Posts: 143
Joined: September 27th, 2014, 3:33 am

Re: Neato going in reverse and in circles

Postby glnc222 » November 9th, 2014, 4:53 pm

I thought I had seen mentioned new vacuums lacking a window cover on the wall sensor, though used on cliff sensors (same part) obviously more exposed. A replacement Wall Sensor did not have it and worked well for months. I did not notice the old one could be removed and transferred.
Bubble wrap packaging thin plastic is probably good. Acryllic, in poster and picture frames, is IR transparent and could be used, just glue. There is no dust access into the case through the uncovered part and the recess pretty well protects the emmitter and receiver plastic domes. Maybe the window is easier to clean -- or even more prone to need cleaning...

Correction: dirt on the Cliff Sensors prevents detecting cliffs. Only the Wall Sensor drives it in circles.
glnc222
Robot Master
 
Posts: 4616
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: Neato going in reverse and in circles

Postby Lewiy » November 10th, 2014, 4:55 am

The photo shows the cover glass with a broken clip on the left. The broken clip periodically closed receiver. Then my Neato began to maneuver. It ran away permanently from the cliff. And it looked like running in a circle.
Attachments
Glass.jpg
Lewiy
Robot Master
 
Posts: 143
Joined: September 27th, 2014, 3:33 am

Re: Neato going in reverse and in circles

Postby neat99 » November 11th, 2014, 10:40 pm

I just want the Neato to run and complete 3 decent cycles without it having to intermittently run in circles or stop with a "clear my path" error. I'm not mechanically inclined to open it up. If the wall or cliff sensor are the probable culprits, what will happen if I cover them with tape? My apartment doesn't have stairs so no need for cliff sensor.
neat99
 
Posts: 35
Joined: June 18th, 2013, 1:11 pm

Re: Neato going in reverse and in circles

Postby vic7767 » November 11th, 2014, 10:54 pm

You're talking about two different issues with your Neato. The "Clear my path" is going to be a Lidar issue. Going in circles may be caused by bump sensor and/or cliff sensors. If you want to disable the cliff sensors you will need to find some material (possibly quality white paper) that will reflect the IRed beam toward the detector. Just using tape may not be the correct solution.
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 14409
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: Neato going in reverse and in circles

Postby neat99 » November 11th, 2014, 11:27 pm

Thanks Vic. The "moving-backwards-in-circles" issue is usually followed by the clear my path issue (not all the time but sometimes). I would get a clear my path error, so I press resume, then it would move backwards in circles. :(. What I do is repeatedly long press the power button until it stops moving backwards and starts moving forward as in a normal run.

Why would it resume a fresh normal run after reset seems to indicate a software issue rather than hardware. I don't know and just guessing. Is there some way to stop the unit from intermittently traveling backwards in circles?
neat99
 
Posts: 35
Joined: June 18th, 2013, 1:11 pm

Re: Neato going in reverse and in circles

Postby vic7767 » November 11th, 2014, 11:39 pm

There is but you will need to identify the complaining sensor that signals the MCU to begin the avoidance maneuver. That may require you to hook up the Neato USB port to your PC, go the the Neatorobotics web site and download the new driver that will be needed to query the Neato via the comm port. Once the offending sensor is discovered your solution gets very easy.
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 14409
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: Neato going in reverse and in circles

Postby neat99 » November 15th, 2014, 8:15 am

Thanks Vic. Will do as you suggested. What am I looking for? What commands should I execute? In your experience what is the offending sensor and how will I fix it?
neat99
 
Posts: 35
Joined: June 18th, 2013, 1:11 pm

Re: Neato going in reverse and in circles

Postby Lewiy » November 15th, 2014, 9:19 am

neat99 wrote:...What commands should I execute?...

You can try NeatoControl to check all Neato sensors and to see how the lidar draws the perimeter. The program is free, and it has an English interface. Need to install a driver before. If you choose to use this program, do not forget to disconnect the software before you disconnect the USB cord from the unit.
http://hex.name/_media/programs/neatocontrol.zip
Lewiy
Robot Master
 
Posts: 143
Joined: September 27th, 2014, 3:33 am

Next

Return to Neato Robotics

Who is online

Users browsing this forum: Snokia, twistdh, vic7767, zebgelatchi and 359 guests