XV-21 PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO CLEAN

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

XV-21 PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO CLEAN

Postby paulinhop » October 6th, 2015, 4:56 pm

Guys,

My neato xv-21 id displaying the message:
PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO CLEAN.

But there is no cable plugged in, i attached the image with the error.


Is there a way to make the robot ignore this message and work? or some work around?
Attachments
20151006_175212.jpg
paulinhop
 
Posts: 5
Joined: October 6th, 2015, 4:51 pm

Re: XV-21 PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO C

Postby vic7767 » October 6th, 2015, 6:09 pm

You might possibly clear the error by plugging in a cable and then unplug it.
Roomba and Neato Mods, come visit: http://www.vic7767.com/

http://www.Robot-Doc.com/
User avatar
vic7767
Robot Master
 
Posts: 14370
Joined: January 14th, 2006, 8:31 pm
Location: Haughton Louisiana - USA

Re: XV-21 PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO C

Postby glnc222 » October 6th, 2015, 6:34 pm

Does it even have a jack to plug in a cable? Later models do not.

If it does have a jack, there can be a switch inside the jack operated by inserting a plug, and this switch could be stuck. Not sure how this one constructed.

Reset the cpu by holding the power button down 25 seconds.
glnc222
Robot Master
 
Posts: 4538
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: XV-21 PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO C

Postby paulinhop » October 6th, 2015, 11:36 pm

vic7767 wrote:You might possibly clear the error by plugging in a cable and then unplug it.



I dont think there is a cable or place to plug in.
paulinhop
 
Posts: 5
Joined: October 6th, 2015, 4:51 pm

Re: XV-21 PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO C

Postby paulinhop » October 6th, 2015, 11:37 pm

glnc222 wrote:Does it even have a jack to plug in a cable? Later models do not.

If it does have a jack, there can be a switch inside the jack operated by inserting a plug, and this switch could be stuck. Not sure how this one constructed.

Reset the cpu by holding the power button down 25 seconds.



It does not have a jack to plug the cable in. Only usb and it is not plugged in.
paulinhop
 
Posts: 5
Joined: October 6th, 2015, 4:51 pm

Re: XV-21 PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO C

Postby glnc222 » October 7th, 2015, 4:40 am

Then the error message is a software defect in the particular model. There could be either hardware or software problems. All the error messages may exist in the software, but something tells the system not to use that particular message when there is no cable to unplug. This could be one of the differences between v3.2 and prior, with the old cpu only capable of using v3.1. There is no way to tell in detail. The power circuits could have a fault which produces a condition used by software for the cable, which could never occur if the circuits were good. The circuit board would have to be analyzed by engineers to tell if this is possible.
glnc222
Robot Master
 
Posts: 4538
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: XV-21 PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO C

Postby mfortuna » October 7th, 2015, 7:01 am

Roombas had a failure similar to this. A faulty diode caused the MCU to read a bit that indicated it had a charger attached. So the roomba would sit there and pretend it was charging. One bad $0.02 component is all it takes.
Mike
Reds x 3, Dirt Dog, Disco (now a parts bot), Create, Scooba 350, and Security Dawg
Evolution Mint
Neato XV-11
User avatar
mfortuna
Robot Master
 
Posts: 5767
Joined: February 5th, 2006, 10:35 am
Location: NH

Re: XV-21 PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO C

Postby glnc222 » October 7th, 2015, 12:54 pm

The Neato diode D14 on the system board is associated with locking the unit in charging mode. Some of those diodes were not up to spec and burn out under load. http://www.robotreviews.com/chat/viewtopic.php?f=20&t=17617&p=127974&hilit=stuck+charging#p127974
Theoretically this might produce the error message, though I think it showed as a blinking indicator light as well, not sure.

[edit] A French user just reported this same error message. The Schotky diode D14 has been replaced a lot in Europe.
glnc222
Robot Master
 
Posts: 4538
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: XV-21 PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO C

Postby paulinhop » October 7th, 2015, 11:09 pm

Ill check into this, i'm from brazil i cant send it to repair, i have to figure it out by myself. What i know is, when i use the neato control software (made by someone in this forum), everything works when i test it out. If there is a way to simply clear the error message i'm pretty sure it would work.
paulinhop
 
Posts: 5
Joined: October 6th, 2015, 4:51 pm

Re: XV-21 PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO C

Postby glnc222 » October 8th, 2015, 3:53 am

Presumably the error occurs when the clean button is pressed; otherwise there would be no need to unplug.
If the hardware component is broken, the error will occur again when cleaning even if the software is rebooted.
The error ought to be cleared by rebooting the software so the unit is not trying to clean. Disconnect the battery with the switch and reconnect, or hold down the power button half a minute. Pressing the button again to clean might create the error again. Perhaps the diode is in a borderline state where it only fails sometimes, I don't know enough whether that is possible for that kind of device. Only experience can tell.
This defect does not have to exist from the start of use. The part could have burned out just recently. Previous running experience is irrelevant. Either it is broken or not.
If you can solder at all it is not a difficult repair. Inexpensive component info in the thread. Get it online, ebay, or locally, or Digi-Key. Shipping from overseas could be some cost. Try Chinese supply, Aliexpress, ebay listings from HK etc.; they seem to subsidize mail.
[edit] Once you disconnect the battery, a short recharge cycle will be requested when reconnected, to calibrate.
glnc222
Robot Master
 
Posts: 4538
Joined: January 23rd, 2012, 9:19 pm
Location: North Carolina, U.S.

Re: XV-21 PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO C

Postby paulinhop » October 8th, 2015, 8:18 am

I just ordered the diode you guys talked about, when it arrive ill make the solder and let you guys know if it worked.

btw i already tried disconnect the batteries, press the power button for half a minute, etc..
paulinhop
 
Posts: 5
Joined: October 6th, 2015, 4:51 pm

Re: XV-21 PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO C

Postby Medtech » October 13th, 2015, 4:19 am

paulinhop
remove the work from the base, set on the floor and press the start button, you change the display will turn off to the proposal cord?
Thank you GOOGLE translator for the freedom of communication.
User avatar
Medtech
Robot Addict
 
Posts: 126
Joined: October 17th, 2014, 3:12 pm
Location: Moscow Russia

Re: XV-21 PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO C

Postby funkylosik » January 27th, 2017, 1:40 pm

paulinhop wrote:I just ordered the diode you guys talked about, when it arrive ill make the solder and let you guys know if it worked.

Did that diode help?
I have exactly the same issue. It started after ~5 perfect cleaning cycles on new LiIon batteries (from Anewpow, so it has controller inside and tried to copy NiMh behavior). I bought them to replace already exhausted NiMh ones.

I've also ordered this B540 diode (D14 in schematics), disassembled Neato (so many screws!), tested the existing diode with multimeter and it seemed fine, allowing for current to pass through only in one direction, which made me think that replacing may not fix this. Soldered new diode and tried to start cleaning. It worked, but only for 1 cycle. In the night, while charging, Neato yelled regarding (now different) 0002 error. And after I dismissed it, Neato wouldn't start, showing that same old "Please unplug my power cable..." message.

So replacing D14 didn't help in my case.
Maybe you have fixed it in somehow different way?
funkylosik
 
Posts: 2
Joined: January 27th, 2017, 1:31 pm

Re: XV-21 PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO C

Postby TechGuy » January 27th, 2017, 2:37 pm

The D14 failure symptom is blink orange or red light when Neato is not charging at the dock.

The unplug message is due to dirt got between the switch contacts inside the charging jack. The rubber plug should be in there all the time.

Neato USB + Charge Port.jpg


The following picture shows the internal of the charging jack. When dirt/hair/debris got between the contacts, Neato is thinking that the charger is plugged in.

Image
Charging battery directly: 400 Series, 500 Series,. How to Desolder
For Sale: Black CHM 2 Ball Bearings set
User avatar
TechGuy
Robot Addict
 
Posts: 1494
Joined: February 17th, 2009, 11:52 pm

Re: XV-21 PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO C

Postby funkylosik » January 28th, 2017, 5:30 am

TechGuy wrote:The unplug message is due to dirt got between the switch contacts inside the charging jack.

Woah... So simple. Thanks a lot! Mine used Neato didn't have this rubber plug. Wiggled the jack with metalic clip and it seems to have helped. Now no yelling error messages overnight, 2 cycles of charging in and everything works. I'll figure something out to cover the jack's hole, though.
p.s. At least now I know how to disassemble robot and attached radiator to D14 for future breaks :P
funkylosik
 
Posts: 2
Joined: January 27th, 2017, 1:31 pm

Re: XV-21 PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO C

Postby TechGuy » January 28th, 2017, 9:54 am

It is great to know that my simple method is getting another robot working again.

Put a masking tape or scotch tape over the charging jack to stop debris from getting inside the charging jack.
Charging battery directly: 400 Series, 500 Series,. How to Desolder
For Sale: Black CHM 2 Ball Bearings set
User avatar
TechGuy
Robot Addict
 
Posts: 1494
Joined: February 17th, 2009, 11:52 pm

Re: XV-21 PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO C

Postby _64_ » April 11th, 2017, 8:02 am

Hello, any ideas what I should try, I have neato XV-18 signature

I measured D14 and D15 they are working. Now I even soldered out the DC JACK. So there is no way there could be power cable attached when there is now DC Jack anymore.

Tried the usual stuff like reboot and disconnect and changed battery left, right even tried different batteries.

Image
_64_
 
Posts: 2
Joined: April 11th, 2017, 7:49 am

Re: XV-21 PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO C

Postby mfortuna » April 11th, 2017, 8:19 am

Removing the jack will cause an open. You will need to solder a wire across two connections. Look earlier in this thread for a picture of the jack. It actually has a switch inside of it.
Mike
Reds x 3, Dirt Dog, Disco (now a parts bot), Create, Scooba 350, and Security Dawg
Evolution Mint
Neato XV-11
User avatar
mfortuna
Robot Master
 
Posts: 5767
Joined: February 5th, 2006, 10:35 am
Location: NH

Re: XV-21 PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO C

Postby TechGuy » April 11th, 2017, 12:09 pm

Although the note on my image refers to Roomba, but it still applies to Neato with a charging jack. _64_ may be confused by that reference.
Charging battery directly: 400 Series, 500 Series,. How to Desolder
For Sale: Black CHM 2 Ball Bearings set
User avatar
TechGuy
Robot Addict
 
Posts: 1494
Joined: February 17th, 2009, 11:52 pm

Re: XV-21 PLEASE UNPLUG MY POWER CABLE WHEN YOU WANT ME TO C

Postby _64_ » April 11th, 2017, 12:16 pm

Yes, I soldered ugly short circuit and it worked. Thank you
Attachments
DSC_0019.JPG
_64_
 
Posts: 2
Joined: April 11th, 2017, 7:49 am


Return to Neato Robotics

Who is online

Users browsing this forum: allidad, Harry007x1, TechGuy and 341 guests