"Empty dirt bin & filter and clean drop & wall sensors" Erro

News and information about the Neato XV-11 Robotic Vacuum. All discussion and troubleshooting questions go here.

"Empty dirt bin & filter and clean drop & wall sensors" Erro

Postby pumabr » December 10th, 2018, 10:26 am

Hi! I need some help identifying a error that is insistently happening with my Neato D5 Connected.

I bought last October a Neato Botvac Connected D5 through the website www.myrobotcenter.eu. Initially the robot seemed to work properly, but in about a week of use it stopped working. The vacuum cleaner refused to start, displaying an "Empty dirt bin & filter and clean drop & wall sensors" error. I did all the cleaning procedures indicated by the user manual and the videos provided by Neato, but the error persisted. So I contacted the seller and Neato, and soon MyRobotCenter set out to replace the robot with a new one. In the meantime, I asked both about what could be the reason for that error, since I was sure the dirt bin, filter and sensors were clean, but no one answered me despite my insistence.

Last week I received the replacement robot. However this one did not seem to have a navigation as consistent as the first robot. Because of that, yesterday I tried to reset the robot as indicated in the user manual to see if the navigation problem was solved. At the end of the process the same error with the first robot occurred again.

When I search about this error on the internet, I find nothing. So I assume this error is not common... does anyone know what might be causing this error?

Thanks in advance for all the answers!
pumabr
 
Posts: 2
Joined: December 10th, 2018, 10:11 am

Re: "Empty dirt bin & filter and clean drop & wall sensors"

Postby HiTec » December 10th, 2018, 1:46 pm

The dirt bin sensor is stuck and the robot doesnt recognize that you are emptying the dirt bin -> Robot refuses to drive because it estimates that the bin is full.

Its the small round rubber button, near the led indicators. You can see it when you remove the dirt bin. Just slightly touch it so it will pop back up and the problem is solved. You can also lubricate it with some non-conducting spray, using q-tip to help its operation. Do not use silicone spray as it will melt the button.

This is pretty common problem for Neatos that have been a long time without use (dirt bin always attached). It kind of deadens the dirt bin sensor rubber button cap. It will start working when you use it normally.

Also adjust the dirt bin reminder time from the app to max, so it doesnt tell you to empty it after every 60 minutes of cleaning.
HiTec
Robot Groupie
 
Posts: 91
Joined: February 8th, 2015, 8:17 am

Re: "Empty dirt bin & filter and clean drop & wall sensors"

Postby pumabr » December 22nd, 2018, 1:25 am

Hi HiTec!

I apologize for just replying now, the Christmas season always leaves us little free time.

Thanks for your help! That was indeed the problem. After I have pressed this button a few times, the robot has returned to normal operation. Unfortunately Neato's assistance did not tell me anything about the dust bin sensor the first time I had this problem. This time Neato gave me a much more complete answer, which included also checking this button. The problem was they took 9 days to respond to me...

Here is a photo of the button, if someone needs this information in the future:

Image

Again thank you very much for your help, if it were not for you I would have returned this robot for the second time and would have asked for full refund!
pumabr
 
Posts: 2
Joined: December 10th, 2018, 10:11 am

Re: "Empty dirt bin & filter and clean drop & wall sensors"

Postby HiTec » December 26th, 2018, 7:03 am

Thanks for the update, good to hear that its okay now!

And not a problem, always glad to help!
HiTec
Robot Groupie
 
Posts: 91
Joined: February 8th, 2015, 8:17 am


Return to Neato Robotics

Who is online

Users browsing this forum: BrettS, funnyfsdfsdaf-123, im1kissfan, jdong, leonicholson, Miles267, NoJimForHome, raidencmc and 396 guests