S9+ - Has anyone noticed this?

The very latest news and updates for the iRobot Roomba robotic vacuum, the Scooba Robotic Washer and the Dirt Dog workshop sweeper. All discussion and troubleshooting questions go here.

Re: S9+ - Has anyone noticed this?

Postby Transammatt » July 7th, 2019, 9:39 pm

Yes I hope software can fix this.i do believe in 3 or 4 month this will be a great robot. My trouble is this little guy will not run on thick carpet. So many reviews on Best Buy’s website about them sending it back because it will not move on carpet and gets stuck all the time. I wanted to make the s9 work so badly but I have return it. I’m going back to the i7+.at least this will move on carpet!
Matt
Matt
Transammatt
 
Posts: 42
Joined: February 25th, 2017, 9:47 am

Re: S9+ - Has anyone noticed this?

Postby hourobotguy » July 8th, 2019, 9:02 pm

Got my replacement robot. Was so smooth and slowed down for everything, including table legs - at first... After the first clean, I initiated a second one. It then proceeded to slam into everything. I was so excited when I got home...

::: sigh :::

It’s more than likely software related... I’m going to put painters tape on the bumper until they update the software.
hourobotguy
 
Posts: 9
Joined: July 3rd, 2019, 11:44 am

Re: S9+ - Has anyone noticed this?

Postby Kz1s » July 8th, 2019, 9:07 pm

hourobotguy wrote:Got my replacement robot. Was so smooth and slowed down for everything, including table legs - at first... After the first clean, I initiated a second one. It then proceeded to slam into everything. I was so excited when I got home...

::: sigh :::

It’s more than likely software related... I’m going to put painters tape on the bumper until they update the software.



That’s just great *eyeroll* I contacted irobot to check status on my case with their senior support team. So far they don’t have any updates but it’s been there since July 3rd so we’ll see. My s9 is pretty beat up in the front but the tape should help till they get all this figured out.
Kz1s
 
Posts: 18
Joined: July 2nd, 2019, 12:44 am

Re: S9+ - Has anyone noticed this?

Postby hourobotguy » July 8th, 2019, 10:33 pm

Added the tape to my robot. This will stay on until they figure out what's going on with the software. I will report it again so the software engineering team can take a look at it.
Attachments
IMG_3048.jpg
IMG_3046.jpg
hourobotguy
 
Posts: 9
Joined: July 3rd, 2019, 11:44 am

Re: S9+ - Has anyone noticed this?

Postby hourobotguy » July 8th, 2019, 10:37 pm

TheStriker095 wrote:I also conducted similar tests using my phone camera, the sensor has the same issue on all 4 replacement units I have received. I think I've decided to just return the Roomba s9 and await next year's model which hopefully resolves the issues with the bumper sensor and side brush design.

As a side note, the Braava m6 is an excellent addition to the Roomba i7+

I love my Braava m6. It's a very good robot mop! I wish it vibrated like my Braava 240t
hourobotguy
 
Posts: 9
Joined: July 3rd, 2019, 11:44 am

Re: S9+ - Has anyone noticed this?

Postby bytemaster0 » July 9th, 2019, 6:33 pm

So, I'm having the same issue. Turns out the firmware update caused a reboot, which temporarily solved the problem. My S9+ is back to bashing walls.
bytemaster0
 
Posts: 43
Joined: October 15th, 2018, 3:48 pm

Re: S9+ - Has anyone noticed this?

Postby Kz1s » July 9th, 2019, 6:51 pm

bytemaster0 wrote:So, I'm having the same issue. Turns out the firmware update caused a reboot, which temporarily solved the problem. My S9+ is back to bashing walls.


Nice, make sure you report to Roomba support. Idk if they can link all these cases together. I can provide my case number. I still haven’t heard anything as of yet. Will update once I’ve heard.
Last edited by Kz1s on July 9th, 2019, 6:56 pm, edited 1 time in total.
Kz1s
 
Posts: 18
Joined: July 2nd, 2019, 12:44 am

Re: S9+ - Has anyone noticed this?

Postby bytemaster0 » July 9th, 2019, 6:55 pm

They've asked me to take videos. Anyone who calls will be asked to take videos, they've said. Will do so tonight.
bytemaster0
 
Posts: 43
Joined: October 15th, 2018, 3:48 pm

Re: S9+ - Has anyone noticed this?

Postby Kz1s » July 9th, 2019, 8:50 pm

bytemaster0 wrote:They've asked me to take videos. Anyone who calls will be asked to take videos, they've said. Will do so tonight.


So they said anyone who’s calling to report this particular issue will be asked to take videos? To me that indicates multiple people reporting and they are aware.
Kz1s
 
Posts: 18
Joined: July 2nd, 2019, 12:44 am

Re: S9+ - Has anyone noticed this?

Postby bytemaster0 » July 9th, 2019, 9:55 pm

I actually am not so sure about that. Reason is I think they are defaulting to ask anyone with a repeatable issue to send a video. Might be their new SOP.
bytemaster0
 
Posts: 43
Joined: October 15th, 2018, 3:48 pm

Re: S9+ - Has anyone noticed this?

Postby Julian » July 10th, 2019, 8:03 am

I'm beginning to wonder whether anyone who has the s9+ ISN'T having this issue. Anyone?

By the way, as an alternative to painters' tape I think that, assuming I go ahead with an s9+ purchase, I'm going to use a strip of self-adhesive draft proofing strip such as this...

https://www.homebase.co.uk/extra-thick- ... 5m_p412763

There are lots of other choices, less thick versions, rubbed U and E profiles etc...

https://www.homebase.co.uk/our-range/bu ... -excluders

UK links but I'm sure all of this stuff is available in any country where a Roomba s9+ is shipping although maybe draft excluders aren't as big a thing in southern Texas as in the North of England for instance.

Most of these strips are also available in white which, given that I have white skirting boards, might make more sense to minimise the chance of getting visible scrape marks on the skirtings but I can't help thinking that it's going to make my s9+ the equivalent of someone wearing a white tie with a black shirt, a fashion statement that always makes me cringe, and I'm not sure that I can live with my Roomba dressed like that!
Julian
Robot Addict
 
Posts: 131
Joined: May 29th, 2009, 7:23 pm

Re: S9+ - Has anyone noticed this?

Postby RTC » July 10th, 2019, 12:32 pm

oops
Last edited by RTC on July 10th, 2019, 12:41 pm, edited 1 time in total.
Technologist (i.e. one who studies technologies)

From the earliest "sticks and stones" technologies of our prehuman ancestors to the latest "high tech" technologies of today, I like studying it all!
RTC
Robot Addict
 
Posts: 162
Joined: August 23rd, 2018, 7:23 pm
Location: Lost someplace in Montana, USA

Re: S9+ - Has anyone noticed this?

Postby RTC » July 10th, 2019, 12:32 pm

Julian wrote:By the way, as an alternative to painters' tape I think that, assuming I go ahead with an s9+ purchase, I'm going to use a strip of self-adhesive draft proofing strip such as this...

https://www.homebase.co.uk/extra-thick- ... 5m_p412763

There are lots of other choices, less thick versions, rubbed U and E profiles etc...

https://www.homebase.co.uk/our-range/bu ... -excluders

UK links but I'm sure all of this stuff is available in any country where a Roomba s9+ is shipping although maybe draft excluders aren't as big a thing in southern Texas as in the North of England for instance.


One can pick these things up at any local walk in hardware store in the US (e.g. Ace, Doit Best, Home Depot, Lowes, mom & pop).
All the northern states get quite cold and windy! There is also a "fad" here for tight energy efficient buildings, so even in Texas, New Mexico, Arizona, etc. they would use these things to prevent loss of their air conditioning to the heat outside.
Technologist (i.e. one who studies technologies)

From the earliest "sticks and stones" technologies of our prehuman ancestors to the latest "high tech" technologies of today, I like studying it all!
RTC
Robot Addict
 
Posts: 162
Joined: August 23rd, 2018, 7:23 pm
Location: Lost someplace in Montana, USA

Re: S9+ - Has anyone noticed this?

Postby TheStriker095 » July 11th, 2019, 1:53 pm

After waiting nearly a week I have finally heard back from iRobot and their escalation team. Unfortunately they still appear to be ignoring that this issue appears to be impacting a significant amount if not all s9's and have simply offered yet another replacement. This will be the 5th unit and I am not at all confident that the issue would be resolved. I have refused the replacement and expressed my concerns on how a flagship device appears to have an issue that is impacting a significant number of customers. I have requested a callback from their head office to discuss the issue further and will report back when that concludes.

Each day I consider returning the unit all together, I hope iRobot acknowledges that this is a real problem and needs to be resolved quickly.
TheStriker095
 
Posts: 7
Joined: June 21st, 2019, 1:14 am

Re: S9+ - Has anyone noticed this?

Postby Kz1s » July 11th, 2019, 2:02 pm

TheStriker095 wrote:After waiting nearly a week I have finally heard back from iRobot and their escalation team. Unfortunately they still appear to be ignoring that this issue appears to be impacting a significant amount if not all s9's and have simply offered yet another replacement. This will be the 5th unit and I am not at all confident that the issue would be resolved. I have refused the replacement and expressed my concerns on how a flagship device appears to have an issue that is impacting a significant number of customers. I have requested a callback from their head office to discuss the issue further and will report back when that concludes.

Each day I consider returning the unit all together, I hope iRobot acknowledges that this is a real problem and needs to be resolved quickly.



They called me yesterday and offered replacement. Due to the noise issues I’ve had and the sensor problems I said ok and they’re sending it. This will be the first replacement.

Something new to note though, I took my battery out of the bot for approx 20 minutes. Put it back in, and so far since then the sensor has not went offline. I keep checking and thinking it will but it hasn’t. I believe I did the battery pull on Sunday. I’d be curious if someone else tried it and had the same result.
Kz1s
 
Posts: 18
Joined: July 2nd, 2019, 12:44 am

Re: S9+ - Has anyone noticed this?

Postby bytemaster0 » July 12th, 2019, 2:38 pm

Latest conversation thread with them:
Me: "This clearly seems to affect a large number of users, and replacing robots has not solved the issue for those users either (I've seen posts about 4 replacement units for the same person, each with the same eventual problem.) As an update, I was able to run 3-4 cleaning cycles over about 1-1.5 days until the LIDAR/IR proximity sensor was once more turned off and the S9+ started bashing into walls again. I've just rebooted and it's acting the way it should again. Makes me also wonder if my trained maps are all slightly messed up due to the IR units not working all the time - the "3D sensor" wasn't 3D sensing, though the maps do work in general.

Rebooting every other day is pretty nutty given the super steep price for these units. At the moment, I feel like I'm beta testing your units, and should be paid! Expediency in resolving the issue would be greatly appreciated."

iRobot: "We certainly understand and we have noted this behavior. This is likely a software issue and we are currently looking into a resolution with our team.

It was never our intention for you to be experiencing this behavior with your the new Roomba s9 plus. We appreciate your understanding on this matter as we are working diligently to have this resolved soon."
bytemaster0
 
Posts: 43
Joined: October 15th, 2018, 3:48 pm

Re: S9+ - Has anyone noticed this?

Postby RTC » July 13th, 2019, 1:44 am

bytemaster0 wrote:Latest conversation thread with them:
Me: "Rebooting every other day is pretty nutty given the super steep price for these units. At the moment, I feel like I'm beta testing your units, and should be paid! Expediency in resolving the issue would be greatly appreciated


More likely alpha testing.
Technologist (i.e. one who studies technologies)

From the earliest "sticks and stones" technologies of our prehuman ancestors to the latest "high tech" technologies of today, I like studying it all!
RTC
Robot Addict
 
Posts: 162
Joined: August 23rd, 2018, 7:23 pm
Location: Lost someplace in Montana, USA

Re: S9+ - Has anyone noticed this?

Postby Tripmeister » July 13th, 2019, 4:48 pm

Here's something that my S9+ has been doing that I finally got on camera...

Backstory: Occasionally the robot will go out for a job while I'm at work, and then I never get an alert about it finishing the job. I'll check the app and the robot will have a battery sitting at 0% and not located anywhere near the charging bay.

I wasn't quite sure why this was happening, as it didn't happen every time. However, I came home early the other day and captured it repeating the same 3-4 motions over and over pretty close to where the robot was ending with 0% battery.

https://www.youtube.com/watch?v=7a_hJB3 ... e=youtu.be

(Shortly after the video ends I pushed it 3 inches from where it was and it merrily went on cleaning as normal.)
Tripmeister
 
Posts: 9
Joined: March 15th, 2017, 11:02 pm

Re: S9+ - Has anyone noticed this?

Postby bytemaster0 » July 14th, 2019, 12:27 am

What firmware version are you running?
bytemaster0
 
Posts: 43
Joined: October 15th, 2018, 3:48 pm

Re: S9+ - Has anyone noticed this?

Postby Tripmeister » July 14th, 2019, 1:47 pm

bytemaster0 wrote:What firmware version are you running?


1.14.22
Tripmeister
 
Posts: 9
Joined: March 15th, 2017, 11:02 pm

PreviousNext

Return to iRobot Roomba and Scooba Chat

Who is online

Users browsing this forum: BrettS, dboston55, lanchez, leonicholson, Miles267, Per L, vic7767 and 460 guests