To Anyone Else Having "Erratic Behavior" with a Neato

Specifically, the Neato in question is a XV-21. "Erratic Behavior," as defined by Neato, is when your unit attempts to clean the room but does not clean the whole room. I'd like to add that, "it attempts to clean the room, doesn't clean the full room, but says/thinks it did by proposing itself 'finished' (after less than 5 minutes) and returns to it's base."

 

I just recently replaced the laser for my Neato (due to error 4000) but it started having the aforementioned issue. It turned out that, when I removed the upper portion of my Neato (which has the power button on it) the cable connecting the side laser (on the Neato's left) came unplugged from the motherboard. Not only did the wire itself come unplugged, however, so did the plastic housing unit on the motherboard. So that, when I plugged it back in, I DID SO BACKWARDS. When I went in the second time, after getting some troubleshooting help from Neato that iscolated it as the laser or the wheel, I'd take a closer look and there it was. 

 

I hope that can help someone else, if you have the same issue (I'd actually ordered a used Neato off of Ebay and had to return it for this very reason, not knowing it was such an easy fix and having just purchased it). My Neato (Dexter) is now happily chugging along and cleaning, as he should. :)

Categories:

Online forum users

Who is online In total there are 223 users online :: 18 registered, 0 hidden and 205 guests
Registered users: ASTMedic, Bing [Bot], bob61, Botty, fufu, fuzzydunlop, Google [Bot], Google Feedfetcher, householdme, im1kissfan, KeldBroe, Legolas84, magura, Majestic-12 [Bot], Miles267, Staticx071, teokakav, vic7767

Poll

User login

Subscribe to RSS Feed

Syndicate content

Show your support

   

Twitter

robotsadmin