Roomba 531 quite sick

Very " new here" Not sure if im in the right spot but I will learn, so no barking or biting please. I have a Roomba 531. The problem started with a red charging error error 5. I checked the charger voltage at it was putting out 21.6 v at plug end going into the machine. Took the battery out and it read 6.2. This Is a replaced battery from meltasta 6400mah.the battery had the smelt burn to it. The battery was naturally just over warrant so I cut it open and the control board had a Burt mosfet and resistor.i put another battery pack in and won't boot up. I Completely tore it down to its bones and checked the motherboard for any signs of burnt components, bad solder joints bad wires or connections. Everything looks good. The power at vbat is 14.5v and none of the LEDs are lite up on the board. I know basic electronics and have a pretty good idea of what I am looking at. But without a schematic it's like looking for a needle in a hay stack. I tried doing spot doc but it didn't respond to anything.can someone help me find some things to check for a starting point or where I may find a form on this type of problem dboston55
Categories:

Online forum users

Who is online In total there are 159 users online :: 8 registered, 0 hidden and 151 guests
Registered users: BCCISProf, Bing [Bot], Google [Bot], Google Feedfetcher, im1kissfan, johnnyh, leonicholson, mfortuna

Poll

User login

Subscribe to RSS Feed

Syndicate content

Show your support

   

Twitter

robotsadmin